Дали автоматските ажурирања не успеваат во WordPress? FTP не успеа?

WordPressНеодамна, имавме клиент кој ги конфигурираше своите сервери за употреба со WordPress. Кога неодамнешниот 3.04 безбедност ажурирањето дојде преку, имаше извесно чувство на итност да се инсталира оваа верзија на сите наши клиенти. Сепак, овој конкретен клиент секогаш бараше да го ажурираме WordPress рачно… процес не за слабо срце!

Ние не би го добиле типичното „не може да пишува датотеки”Грешка на овој блог. Наместо тоа, ни беше даден екран со најавување FTP. Проблемот беше во тоа што ќе ги пополниме ингеренциите на FTP и тоа ќе се случи сепак не успеваат… Овој пат засновано на добри квалификации!

Стапив во контакт со нашите пријатели во Центрите за податоци за живот, во Индијана најголем центар за податоци, бидејќи тие имаат некои гикови на Apache и имаат конфигурирано свои сервери. Тие ми дадоа едноставно решение - додавање на ингеренциите на FTP директно во WP-config.php датотека за тврд код на ингеренциите на FTP:

дефинирај ('FTP_HOST', 'localhost'); дефинирај ('FTP_USER', 'корисничко име'); дефинирај ('FTP_PASS', 'лозинка');

Од некоја причина, идентичните квалификации што не работеа во форма, функционираа совршено кога беа ставени во конфигурациската датотека! Исто така, тоа го прави WordPress да дејствува исто како што би работел без потреба од FTP. само кликнете на ажурирање и одете!

4 Коментари

  1. 1

    Доживеав грешки во ажурирањето на WordPress со автоматско ажурирање откако повторно го изградив мојот сервер и ја превртив новата инсталација на WordPress. Мојот проблем произлезе од Firefox, а не од WordPress - други може да го доживеат истото прашање ако нивното корисничко име FTP и корисничко име на WordPress се исти како и моите (иако со различна капитализација и лозинка).

    Проблемот е во тоа што Firefox, доколку имате овозможено „запомнете лозинки“, автоматски ќе го коригира корисникот / помине во формата според она што смета дека треба да се заснова на зачуваното во управувачот со лозинки. Во мојот случај, моите квалификации за WordPress беа зачувани, но ингеренциите за FTP не беа, бидејќи тие можат да се користат за SSH на страницата. Луѓето во оваа ситуација можат или привремено да ги оневозможат „запомнете ги лозинките“ во нивните Преференции / Опции кога се обидуваат да користат автоматско ажурирање на WordPress или да применат парче код на WordPress за да го поправат ова однесување.

  2. 2

    Даг,

    Го имав истиот проблем со домашната конструкција на Apache. Излезе дека тоа е резултат на неправилни дозволи и сопственост на одредени датотеки и директориуми.

    http://robspencer.net/auto-update-wordpress-without-ftp/

    Врската погоре даде увид во тоа како да го поправите проблемот без користење на ингеренциите за ftp. Секако, не препорачувам целиот свој директориум за корисници да го наведете на 775 (а јас не), но ова ме доведе во вистинската насока.

    Adam

  3. 3

    За други кои бараат можни решенија: Друг блогер ги реши своите проблеми со автоматско ажурирање, очигледно принудувајќи го неговиот домаќин да користи php5 со додавање на следново во неговата датотека .httaccess:

    AddType x-mapp-php5 .php

  4. 4

    Ви благодариме што го споделивте знаењето, имам проблеми со автоматските ажурирања, но единственото решение што го најдов е да ги деактивирам додатоците, потоа да ги автоматизирам WordPress и конечно да ги реагирам сите приклучоци.

    Овој совет е за различен проблем, но добро е да знаете како да го решите.

    Поздрав од Мексико!

Што мислите?

Оваа страница користи Akismet за намалување на спам. Научете како се обработува вашиот коментар.